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Introduction

This document is provided as an overview
for our new graphics library now stream-
lined for Microsoft Visio. Its intention is
to function as a procedural information
resource rather than a tutorial. Big picture
processes are covered to give the user
famili arity as well as minor trouble-
shooting skills.

Whil e some information may a ppear
obvious to the experienced Visio user, this
manual must appeal to the wide range of
potential users. No matter your skill level,
we strongly suggest reading completely
through this document prior to contacting

Cin w2 o isio us as most questions will be answered
(P')[.Olfcesmonal : herein.
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Visio’s interface was chosen as the plat-
form for the new graphics library due to
its popularity in the business world and
overall ease of use. To access the Graphics

Library you will need to install Microsoft
Visio.

* All graphics included in the BAS Graphic Library are copyright Computrols, Inc.
The Licensee of this software agrees to not make copies or alterations of the BAS
Graphics Library, or any of its components, to be copied or distributed to others.

“Microsoft Visio®” is a registered trademark of Microsoft® Corporation.



Using Microsoft Visio:
A Basic Overview

Visio is a tool used through the business
community to develop formulaic diagrams that
convey complex business concepts, ideas, and
systems. Typical operating procedure involves
having two separate files open simultaneously:
a stencihnd a drawing.

The stencil is the file containing the family of
images used to create a diagram. The drawing
is the file where images from the stencil are
placed (specifically in the “drawing area”). Both
files exist separately so multiple stencils can be
used to create a single document if desired.

Steps to begin creating a Visio drawing:
1. Open Microsoft Visio.

2. At the top menu, select “File > New > New
drawing.”

3. Now open the Graphics Library stencil

by selecting “File > Shapes > Open Stencil.”
4. Browse for the provided file named “CBAS
Graphics Library.vss” and click “Open”
5. The Graphics Library stencil will
appear on the left side of your screen with a
green background.
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Using Microsoft Visio. A Basic Overview

6. Click on an object in the
stencil, hold down, drag, and
drop the object onto your
drawing. Continue this until
your drawing is complete.
7. To view your drawing
close up, select “View >
Zoom” from the top menu,
or use the quick menu
pulldown at the top of the
window. Zooming in on your
drawing can help when you
need to move an object
slightly using the arrow keys
on your keyboard.

8. Microsoft Visio’s Drawing
toolbar can be used to create
a number of additional
graphic elements. You can
access the Drawing toolbar
by selecting from the top
menu “View > Toolbars >
Drawing.” When you use the
rectangle or circle tool to
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Above: The Drawing toolbar can appear as a pallet or “nested” menu.

draw a shape in your document, you can change the line and fill colors. Select the object, then click
the paintbrush icon on the top menu and select a line color. The fill color can be changed by selecting
the paint bucket from the top menu and picking a color. To remove a line or a fill, simply select “No
Line” or “No Fill” from each respective menu.
9. To save your drawing, select File > Save As from the top menu. We suggest making a new folder
where you can organize your drawings for easy reference.
10. Refer to the “Creating BAS Graphics” section for information on exporting your final graphic

Manipulating an object in the drawing area:
1. To move an object already in the drawing area, click and drag it. For
more sensitive increments of movement, select it, and while holding
down a “Shift” key, use the arrow keys on your keyboard.
2. To deselect an object, click anywhere outside of the drawing area
(this appears as the dark gray area of the drawing file’s window).
3. To scale an object, first select it, then while holding down a “Shift”
key, click and drag on one of the green tabs on either side of the object.
4. To rotate an image, select the image, click and hold on the green tab
sticking out from the top of the image. While holding, move your mouse
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Above: Rotating an object.

the objects you want to align together. Go to the top menu and select “Shapes > Align Shapes.”

to rotate the image.

5. Objects will end up on top of one another in the order they are placed
in the drawing. To move one object behind or on top of another object,
right click on that object, select “Shapes > Bring to Front” or “Shapes > Send to Back.”
6. You can neaten a column or row of objects by using the Align feature in Microsoft Visio. Select all

A

window will appear allowing you to choose how the selected objects are aligned.
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Understanding the
BAS Graphics Library
Stencil

We have developed a custom stencil file
containing its own graphic library for use in
developing BAS specific imagery. The mission

of the library is making custom graphics readily
accessible to dealers and sales teams who may
have neither the time nor training to build high
quality imagery for a project’s BAS interface.

To achieve this goal, we developed an inter-
locking “modular” library of HVAC industry
images which can be placed side-to-side, top-to-
bottom, or one over the other in any number of
ways to create finished imagery for export to BAS
editing software.

Among the many elements illustrated in the
Graphics Library are:

- AHUs

- Multiple colors of piping
- Cooling towers

- Sensors

- Coils

- Valves

- Tanks

- Pumps

- Miscellaneous ductwork
- Dampers

- Chillers

- Button graphics

- Custom backgrounds

Through this assortment of modular elements,
a dealer can generate within minutes a complete
screen template and an illustration of the

HVAC mechanics for any particular screen.
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Creating BAS Graphics

Through use of the BAS Graphics Library,
you can quickly develop entire BAS graphics
to complete whole screens in the BAS mterface.
The end product is one single JPG image file
that can then be imported into BAS. The
following is a basic step-by-step approach to
completing a BAS screen exclusively using
the imagery in the graphics library.

NOTE: Steps 2-5 are extremely important to include each
time you begin developing a BAS screen image—even
if you do not intend to use one of the background images
included in the graphics library. These steps ensure your
end product has the correct overall dimensions for use
in BAS.

1. Open a new document and the BAS
Graphics Library stencil file.

2. Drag and drop one of the background images
from the stencil onto the document.
3. At the top menu, select “File > Page Setup.”
4. A small window will appear. Click on the
“Page Size” tab.

5. Select “Size to fit drawing contents” and click
the “Ok” button. The drawing area of your
document will now resize to the dimensions of
the background image you placed.

6. Now that you have a background, you can
begin placing
graphic elements
for your overall
BAS interface
(i.e. menus). This
will include
button graphics,
tabs, or any other
areas where you
might have a
clickable field
placed in the
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Creating BAS Graphics

BAS editor. The graphics library stencil contains a button and a tab graphic, each of which can be
placed multiple times in the drawing area. You can also use Microsoft Visio’s Drawing toolbar to make
rectangles and circles with colored backgrounds and borders, as well as individual lines of various
thicknesses. Quicken the pace of making buttons by copying and pasting the same object until you
have the number you need.

7. A large rectangle can be drawn to create the area where your mechanical illustrations will consistently
appear. It is suggested that this be a very large area so a variety of mechanical HVAC illustrations will
be able to fit. See the example below:

8. It is suggested that you
save the drawing at this
point. This drawing file will
be used as your template for
all future screens you create
for this particular project. It
ensures consistency of your
menu graphics throughout
BAS (objects will not
appear to jump around or
shift one screen to the next).
9. Once you’ve secured a
master template file, save the
drawing under a different name and begin laying out a mechanical illustration using objects from the
BAS Graphics Library stencil.

10. Objects can be stretched by selecting and pulling on any one of the green tabs. This is useful for
horizontal and vertical pipe
and duct graphics that need
to take up more room.
11. When you have
completed a mechanical
HVAC composition, save the
drawing in the folder you
made for the project. Use a
name that briefly, but clearly
describes the particular
drawing. This will help you
locate the drawing later.
12. After saving, you're ready
to export the finished drawing for use as a screen in BAS.

Above: A large rectangle was drawn as the zone for our HVAC illustrations.

Above: A graphic element can be stretched by pulling any of its green tabs.

Note: Make certain you do not place objects or drawn elements (rectangles, lines, etc.) outside of Microsoft Visio’s drawing
area (the white area with the grid pattern). Microsoft Visio will export all graphic elements in a drawing thereby making
your exported composition too long or too tall.




Exporting a Drawing
for Use in BAS

‘When you're satisfied with a drawing, it’s ready
for importing into BAS. To prepare the file for

this, it must be exported from Microsoft Visio.
These steps outline the process you should follow
to make sure your file is exported properly.

1. On the top menu, select “Edit > Select All.”
2. Go to “File > Save As.”

3. Locate the folder you want to export your
graphic to.

4. Name your file in the “File Name” field. DO
NOT use spaces or periods in the file name.
5. Click on the “Save as type” pull down and
scroll down to the selection titled “JPEG File
Interchange Format (*.jpg).” Click the “Save”
button.

6. A window will appear with specific details
that can be modified for your file. You can select
the background color that your file will have (in
case you are not using a background image) and
the image quality (higher quality produces a
larger file size). These preferences are up to you
and will not make-or-break the end product.
7. Under “Resolution,” select “Custom.” In the
first two fields to the right of Custom, enter “72”
in both.

8. Ensure that under “Size” the option “Source”
is selected.

9. Click the “Ok” button.




Importing Objects
Into a Drawing

You may find that you need to add an object
that is not available in the BAS Graphics
Library stencil to a drawing. This might be a
logo for your company, a logo for your client,
or some other job-specific image such as a
location photo or floor plan.

If a job-specific logo needs to appear throughout
all your BAS screens, we suggest importing

that image prior to completing your template
file so it does not need to be imported again
each time you start a new drawing.

The following steps should be taken to import
images:

1. On the top menu, select “Insert > Picture >
From File.”

2. Browse for the image file you want to insert.
3. Select the file and click the “Open” button.
4. The object will appear selected in the drawing
area. You can now manipulate it by scaling,
moving, or rotating like any other object in your
drawing area.

Objects that are imported into Microsoft Visio
become “embedded” in the drawing file. This
means you can use the drawing file
independently on other computers without also
having the files for your imported objects. The
Microsoft Visio drawing saves its own copy of
the object.

Note: If an image with a transparent background is desired,
import an image that was saved as a transparent GIF
(*.gif). Check your photo-editing software manual for how
to produce a transparent GIF.




Sample Graphics

With over 1000 individual renderings, the BAS Graphics library provides a comprehensive
suite of tools for rapidly creating BAS graphics. Included here is an overview of some of
the included graphics.

Duct Pieces

Duct Sensors
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Duct Equipment




Pumps and Cooling Towers
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Large Equipment Chillers







